OptimizeMemory - Advanced RAM optimization tool

Introduction

OptimizeMemory is a handy memory optimizer tool that will keep your computer running faster and efficiently. It increases your system performance by making more memory available for your applications and the operating system.

OptimizeMemory defragments your computer's memory, increasing the efficiency of your CPU and Motherboard caches, recovers memory leaks from poorly behaved applications, flushes unused libraries temporarily out to disk and so on. By all this optimization tricks your favorite applications and games will run faster and efficiently even on old computers.

Using this RAM optimizer utility your computer will achieve superior performance. There is no need to buy additional expensive memory for your computer. OptimizeMemory will defragment system memory for faster access time. OptimizeMemory doesn't modify your system in any way and your system will be even more stable with OptimizeMemory installed.

No matter how much physical memory you have, OptimizeMemory will help keep your computer running faster and efficiently.

OptimizeMemory - Powerful tool for cleaning and optimizing memory on your computer. It increases the overall system performance by providing more efficient usage of your CPU.
OptimizeMemory Main Window


OptimizeMemory - Advanced RAM optimization tool

More Details

OptimizeMemory is a program for cleaning and optimizing MEMORY on your computer. It increases the overall system performance by providing more efficient usage of your CPU. Some of its main features are listed below:

Memory defragmantation
After numerous launches of different programs your memory is messed up, that is especially easy to see after the work of Internet Explorer. The programs will still run, but the overall system performance will become lower. You should know that your CPU has cache (L1, L2) and that certain part of your RAM is written there right before the response to the given region of memory. When your CPU reads some data/commands from cache it's much faster then reading/executing orbitrary commands. Now imagine a situation when the program's code is placed in many different places of your RAM, and that those parts include multiple redirections(pointers) to another ones. How to cache the stuff in such a case? Because of this it happens frequently that wrong and useless data is cached, thus supplying your CPU with a nasty job to find necessary pieces of code by itself. Such a reduction of hit-rate of cache is able to decrease the efficiency of the system regardless of memory size. Memory defragmentation solves this problem, so that your CPU doesn't have to waste its time.

Unloading of Unnecessary Libraries
Many programs including Windows used to load in memory many libraries and it is evident that some of them won't be used instantly. OptimizeMemory finds such modules and unloads them to a swap file. If some of unloaded libraries becomes necessary again it is loaded back in RAM.

Fighting with Memory Leaks
All applications while running allocate certain amount of memory. But it happens oftenly that after quiting the program not all of the allocated space is set free. So the program ain't running any more, and you get some memory that is not actually used and at the same time it can't be allocated by some other program before it's set free. OptimizeMemory finds and removes such memory leaks, thus increasing size of free RAM.

Information about Memory
The program shows a detailed information about total size of physical RAM, free memory and the percentage of its usage by the system. The same information is given about swap file and the business of the CPU.


OptimizeMemory - Advanced RAM optimization tool

Using OptimizeMemory

The program can work in two ways to optimize your MEMORY: by pressing 'Go!', or by configuring it to operate automatically. You may, of course, use the two methods together. By default OptimizeMemory is automatically minimized to system tray after its start (the tray icon displays number of MBs of free RAM), but this and many other options can be changed.

When freeing MEMORY OptimizeMemory can operate in one of the following two different modes:
1. via AutoFree, in which OptimizeMemory automatically balances speed and memory when optimizing
2. you can manually set size of memory and the program will try to free it

In addition, thanks to a command line support you can simplify the general process of freeing MEMORY by adding to your task sheduler the following line:
1. C:\Program Files\OptimizeMemory\OptimizeMemory.exe /opt
This means whenever this command line will be executed OptimizeMemory will run, automatically free memory(in the way/as much) as defined in settings.
2. C:\Program Files\OptimizeMemory\OptimizeMemory.exe /free X
This means whenever this command line will be executed OptimizeMemory will run, automatically free X Mb of memory(in the way/as much).

You can choose whether to log OptimizeMemory's activity, to display report on freeing result or not. You can explore menu 'Settings' and 'Tools' to find other usefull features like: cleaning of clipboard, shutting down/restarting windows, etc.

Since version 2.0 OptimizeMemory is supplied with it's Application Startup Wizard which will help you configure optimal launch parameters of your applications. Now OptimizeMemory will automatically free needed size of RAM before/after program's launch.


OptimizeMemory - Advanced RAM optimization tool

Frequently Asked Questions (FAQ)

Usage related questions:

How do I uninstall OptimizeMemory?
To uninstall OptimizeMemory please go Start -> Programs -> OptimizeMemory -> Uninstall OptimizeMemory

I use other memory managers/optimizers/tweakers. Is OptimizeMemory compatible with them?
 YES!

What is Cache Tuning?
This feature allows both viewing and modification of current Windows settings which determine how your virtual cache and swap file are used. Though you may change memory size values to anything you like, we recommend you to apply the optimal settings. Correctly performed cache tuning usually improves the overall system performance. Note that this feature is available for Win 9X/ME users only.

What is Processor Detection Toolkit?
This feature lets you view detailed information about your CPU, Cache, and Feature Set.

What is OptimizeMemory's Application Startup Wizard?
This is a nice utility that will help you optimize launches of selected programs. With its help you specify minimum size of free RAM needed for the program to run and the least size of RAM that must be free when program quits. At the end of the configuration process you get .trc file. Now all you have to do is double click this file leaving the job to OptimizeMemory.

General questions:

What are the minimum requirements for OptimizeMemory?
OptimizeMemory needs at least 2 Mb of free space, 16 Mb RAM.

I found a bug in OptimizeMemory. What should I do?
Please email us if you encountered an error. In your mail please specify:
Which OS are you running
OptimizeMemory version
And error description of course

Questions about compatibility with other programs:

Does OptimizeMemory run on Win95/Win98/WinME/WinNT/Win2000 and WinXP?
YES! OptimizeMemory was designed to be compatible with all these Windows Operating Systems.

Is there a version available for Linux/Mac?
Not yet, but do check back!


OptimizeMemory - Advanced RAM optimization tool

History

changes in v3.6

- fixed bugs
changes in v3.5

- updated Multi-Language support (English, Russian, Ukrainian, Bulgarian, Chinese, German, Polish, French, Italian)
- fixed bugs
changes in v3.4

- updated Multi-Language support (English, Russian, Ukrainian, Bulgarian, Chinese, German, Polish)
- fixed bugs
changes in v3.31

- New Setup Wizard (very small)
- fixed bugs with Bios Information under Windows 9x/Me
- security update
changes in v3.3

- updated defragmentation engine
- updated Multi-Language support (English, German, Russian, Ukrainian, Bulgarian, Polish)
changes in v3.2

- updated Multi-Language support (English, Russian, Ukrainian, Bulgarian, Polish)
changes in v3.1

- fixed bugs
- updated Multi-Language support (English, Russian, Ukrainian, Bulgarian)
changes in v3.0

- fixed bugs
- added Multi-Language support (English, Russian, Ukrainian)
changes in v2.3

- fixed bugs
- updated resources
changes in v2.2

- fixed bug with support TrueType of fonts
- updated OptimizeMemory's Application Startup Wizard
changes in v2.1

- added integration into Windows Shell
- updated Sensors settings
- updated OptimizeMemory's Application Startup Wizard
- updated documentation
changes in v2.0

- added Processor Detection Toolkit
- added Cache Tuning feature (Win 9X/ME only)
- added OptimizeMemory's Application Startup Wizard
- now user can change style of Sensors
- updated documentation
changes in v1.1:

- updated and fixed small bugs in
StatusBar
ProgressBar
Sensors
TrayIcon
TrackBar
- added big fonts support
- added "Clear IE cache"
- added "Windows Uptime"
- now user can change Hot Keys
changes in v1.0

- first program release